Skip to content

cutil Error With CUDA 5.5

Recently I have had to compile CUDA code that had been written for an anterior version of CUDA 5.0 and encountered errors with an old library.  After a quick google search on the Nvidia website, and some forums, I discovered that the library I was trying to use had been replaced in the latest versions of CUDA. This is a quick fix if you need to compile code that include the following deprecated library:

Simply replace this library with the following :

In the old code the following function was used :

To avoid modifying the multiple files I simply added this line :

Also I replaced all occurrences of :

by :

and  added this line as well :

I was now able to compile the old code, and run it with CUDA 5.5.  I hope this helps.

 

Post a Comment

Your email is never published nor shared. Required fields are marked *